extra_math/Cargo.nix

75 lines
2.4 KiB
Nix

# This file was @generated by cargo2nix 0.11.0.
# It is not intended to be manually edited.
args @ {
release ? true,
rootFeatures ? [
"extra-math/default"
],
rustPackages,
buildRustPackages,
hostPlatform,
hostPlatformCpu ? null,
hostPlatformFeatures ? [],
target ? null,
codegenOpts ? null,
profileOpts ? null,
cargoUnstableFlags ? null,
rustcLinkFlags ? null,
rustcBuildFlags ? null,
mkRustCrate,
rustLib,
lib,
workspaceSrc,
ignoreLockHash,
}: let
nixifiedLockHash = "74f9e44cc52b70b46b1a8e880aaaa90232d5db51c515bd0708c4b6732faf788b";
workspaceSrc =
if args.workspaceSrc == null
then ./.
else args.workspaceSrc;
currentLockHash = builtins.hashFile "sha256" (workspaceSrc + /Cargo.lock);
lockHashIgnored =
if ignoreLockHash
then builtins.trace "Ignoring lock hash" ignoreLockHash
else ignoreLockHash;
in
if !lockHashIgnored && (nixifiedLockHash != currentLockHash)
then throw "Cargo.nix ${nixifiedLockHash} is out of sync with Cargo.lock ${currentLockHash}"
else let
inherit (rustLib) fetchCratesIo fetchCrateLocal fetchCrateGit fetchCrateAlternativeRegistry expandFeatures decideProfile genDrvsByProfile;
profilesByName = {
};
rootFeatures' = expandFeatures rootFeatures;
overridableMkRustCrate = f: let
drvs = genDrvsByProfile profilesByName ({
profile,
profileName,
}:
mkRustCrate ({inherit release profile hostPlatformCpu hostPlatformFeatures target profileOpts codegenOpts cargoUnstableFlags rustcLinkFlags rustcBuildFlags;} // (f profileName)));
in
{
compileMode ? null,
profileName ? decideProfile compileMode release,
}: let
drv = drvs.${profileName};
in
if compileMode == null
then drv
else drv.override {inherit compileMode;};
in {
cargo2nixVersion = "0.11.0";
workspace = {
extra-math = rustPackages.unknown.extra-math."0.2.0";
};
"unknown".extra-math."0.2.0" = overridableMkRustCrate (profileName: rec {
name = "extra-math";
version = "0.2.0";
registry = "unknown";
src = fetchCrateLocal workspaceSrc;
features = builtins.concatLists [
(lib.optional (rootFeatures' ? "extra-math/default") "default")
(lib.optional (rootFeatures' ? "extra-math/u256") "u256")
(lib.optional (rootFeatures' ? "extra-math/unstable") "unstable")
];
});
}