nixos-config/programs/desktop/default.nix

34 lines
556 B
Nix

{ config, pkgs, ... }:
{
imports = [
./steam
./kodi/system-config.nix
./pipewire.nix
./firefox/system.nix
];
home-manager.users.darkkirb.imports =
if config.isGraphical then
[
./home-manager.nix
]
else
[ ];
environment.plasma6.excludePackages = with pkgs.kdePackages; [
elisa
kate
];
networking.firewall.allowedTCPPortRanges = [
{
from = 1714;
to = 1764;
}
];
networking.firewall.allowedUDPPortRanges = [
{
from = 1714;
to = 1764;
}
];
}