This repository has been archived on 2024-10-13. You can view files and clone it, but cannot push or open issues or pull requests.
nix-packages/linux/bcachefs/default.nix
2023-05-17 13:45:03 +00:00

33 lines
795 B
Nix

{
lib,
fetchFromGitHub,
buildLinux,
...
} @ args: let
modDirVersion = "6.3.0";
source = builtins.fromJSON (builtins.readFile ./source.json);
in
buildLinux (args
// {
inherit modDirVersion;
version = "6.3.0+${source.rev}";
src = fetchFromGitHub {
owner = "koverstreet";
repo = "bcachefs";
inherit (source) rev sha256;
};
structuredExtraConfig = with lib.kernel; {
BCACHEFS_FS = module;
BCACHEFS_DEBUG = yes;
KALLSYMS = yes;
KALLSYMS_ALL = yes;
DEBUG_FS = yes;
DYNAMIC_FTRACE = yes;
FTRACE = yes;
};
passthru.updateScript = [
../../scripts/update-git.sh
"github.com/koverstreet/bcachefs"
"linux/bcachefs/source.json"
];
})