manual update
This commit is contained in:
parent
6b944ce1d1
commit
f80956b71c
8 changed files with 133 additions and 68 deletions
|
@ -1,9 +1,9 @@
|
|||
{
|
||||
"url": "https://akkoma.dev/AkkomaGang/admin-fe.git",
|
||||
"rev": "e018d26a5b1099bb65ce42d0998a3fce12f843ca",
|
||||
"date": "2022-11-13T23:15:37+00:00",
|
||||
"path": "/nix/store/hipg2zimmhjpsy7ka96lbisf4r80q8m5-admin-fe",
|
||||
"sha256": "1pzrz8ii080rn8340q4ahqh8fm7yzb1qdnvx36frsiw2ini2sxww",
|
||||
"rev": "0802dc5777e722d5df8bc595e025a6124eb02837",
|
||||
"date": "2022-12-14T12:05:59+00:00",
|
||||
"path": "/nix/store/pqj5iqn2y89qfgd33b9jjbn58cq395nn-admin-fe",
|
||||
"sha256": "0qvr245604yaslvnphx2ybclh51svqi570pzch917jffi8kkr5gr",
|
||||
"fetchLFS": false,
|
||||
"fetchSubmodules": false,
|
||||
"deepClone": false,
|
||||
|
|
|
@ -1,18 +1,18 @@
|
|||
diff --git a/lib/pleroma/web/plugs/http_security_plug.ex b/lib/pleroma/web/plugs/http_security_plug.ex
|
||||
index d1e6cc9d3..4e29355c5 100644
|
||||
index 5f0b775be..fd032d071 100644
|
||||
--- a/lib/pleroma/web/plugs/http_security_plug.ex
|
||||
+++ b/lib/pleroma/web/plugs/http_security_plug.ex
|
||||
@@ -113,12 +113,7 @@ defp csp_string do
|
||||
connect_src
|
||||
end
|
||||
@@ -114,12 +114,7 @@ defp csp_string(conn) do
|
||||
style_src = "style-src 'self' 'unsafe-inline'"
|
||||
font_src = "font-src 'self' data:"
|
||||
|
||||
- script_src =
|
||||
- if Config.get(:env) == :dev do
|
||||
- "script-src 'self' 'unsafe-eval'"
|
||||
- "script-src 'self' 'unsafe-eval' '#{nonce_tag}'"
|
||||
- else
|
||||
- "script-src 'self'"
|
||||
- "script-src 'self' '#{nonce_tag}'"
|
||||
- end
|
||||
+ script_src = "script-src 'self' 'unsafe-eval'"
|
||||
+ script_src = "script-src 'self' 'unsafe-eval' '#{nonce_tag}'"
|
||||
|
||||
report = if report_uri, do: ["report-uri ", report_uri, ";report-to csp-endpoint"]
|
||||
insecure = if scheme == "https", do: "upgrade-insecure-requests"
|
||||
|
|
147
akkoma/mix.nix
147
akkoma/mix.nix
|
@ -232,19 +232,6 @@
|
|||
beamDeps = [];
|
||||
};
|
||||
|
||||
credo = buildMix rec {
|
||||
name = "credo";
|
||||
version = "1.6.7";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "1lvxzksdrc2lbl0rzrww4q5rmayf37q0phcpz2kyvxq7n2zi1qa1";
|
||||
};
|
||||
|
||||
beamDeps = [bunt file_system jason];
|
||||
};
|
||||
|
||||
custom_base = buildMix rec {
|
||||
name = "custom_base";
|
||||
version = "0.2.1";
|
||||
|
@ -297,14 +284,27 @@
|
|||
beamDeps = [];
|
||||
};
|
||||
|
||||
earmark = buildMix rec {
|
||||
name = "earmark";
|
||||
version = "1.4.33";
|
||||
dialyxir = buildMix rec {
|
||||
name = "dialyxir";
|
||||
version = "1.2.0";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "01mfb0c1vq72pira1622cmvaly2p6n4dxwmsrw10i9x0srii7cr1";
|
||||
sha256 = "0qw4zyd86fjwsav744jvz1wpdbmy9nz645xqr9s1d1bs88v221v1";
|
||||
};
|
||||
|
||||
beamDeps = [erlex];
|
||||
};
|
||||
|
||||
earmark = buildMix rec {
|
||||
name = "earmark";
|
||||
version = "1.4.34";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "012mwv4ixll3gmav9v0wzlin2948ghb2imnp20xi6nyqvbrhdcch";
|
||||
};
|
||||
|
||||
beamDeps = [earmark_parser];
|
||||
|
@ -401,6 +401,19 @@
|
|||
beamDeps = [];
|
||||
};
|
||||
|
||||
erlex = buildMix rec {
|
||||
name = "erlex";
|
||||
version = "0.2.6";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "0x8c1j62y748ldvlh46sxzv5514rpzm809vxn594vd7y25by5lif";
|
||||
};
|
||||
|
||||
beamDeps = [];
|
||||
};
|
||||
|
||||
eternal = buildMix rec {
|
||||
name = "eternal";
|
||||
version = "1.2.2";
|
||||
|
@ -596,6 +609,19 @@
|
|||
beamDeps = [];
|
||||
};
|
||||
|
||||
gettext = buildMix rec {
|
||||
name = "gettext";
|
||||
version = "0.20.0";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "0ggb458h60ch3inndqp9xhbailhb0jkq3xnp85sa94sy8dvv20qw";
|
||||
};
|
||||
|
||||
beamDeps = [];
|
||||
};
|
||||
|
||||
hackney = buildRebar3 rec {
|
||||
name = "hackney";
|
||||
version = "1.18.1";
|
||||
|
@ -962,12 +988,12 @@
|
|||
|
||||
open_api_spex = buildMix rec {
|
||||
name = "open_api_spex";
|
||||
version = "3.10.0";
|
||||
version = "3.16.0";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "0rc7q857b8zb9vc4c699arjihca353rzm3bfjc31z0ib7pg2pfrd";
|
||||
sha256 = "0a91jzgq6qp6ba5kxcz8fli2d1l49d8pz8dxikyfhwwbci5f42xv";
|
||||
};
|
||||
|
||||
beamDeps = [jason plug poison];
|
||||
|
@ -1027,12 +1053,12 @@
|
|||
|
||||
phoenix_live_dashboard = buildMix rec {
|
||||
name = "phoenix_live_dashboard";
|
||||
version = "0.6.5";
|
||||
version = "0.7.2";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "0lmq1m7k465i9mzw35l7bx69n85mibwzd76976840r43sw6sakzg";
|
||||
sha256 = "1dq5vj1a6fzclr3fwj7y8rg2xq3yigvgqc3aaq664fvs7h3dypqf";
|
||||
};
|
||||
|
||||
beamDeps = [ecto ecto_psql_extras mime phoenix_live_view telemetry_metrics];
|
||||
|
@ -1040,15 +1066,15 @@
|
|||
|
||||
phoenix_live_view = buildMix rec {
|
||||
name = "phoenix_live_view";
|
||||
version = "0.17.12";
|
||||
version = "0.18.3";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "1j4r1pjl60hphan7mf0fn60cnqkdc7hah9zmf4sz8vy1mbhdavdg";
|
||||
sha256 = "1cl1rsfhg4aqazd2nswb3c3an04g7hwnacq8nzf1gq36m1vm3168";
|
||||
};
|
||||
|
||||
beamDeps = [jason phoenix phoenix_html telemetry];
|
||||
beamDeps = [jason phoenix phoenix_html phoenix_template phoenix_view telemetry];
|
||||
};
|
||||
|
||||
phoenix_pubsub = buildMix rec {
|
||||
|
@ -1105,12 +1131,12 @@
|
|||
|
||||
plug = buildMix rec {
|
||||
name = "plug";
|
||||
version = "1.10.4";
|
||||
version = "1.14.0";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "1874ixvvjklg0hnxr6d990qzarvvfxhd4s35c5bfqbixwwzj67md";
|
||||
sha256 = "056wkb1b17mh5h9ncs2vbswvpjsm2iqc580nmyrvgznlqwr080mz";
|
||||
};
|
||||
|
||||
beamDeps = [mime plug_crypto telemetry];
|
||||
|
@ -1207,19 +1233,6 @@
|
|||
beamDeps = [];
|
||||
};
|
||||
|
||||
quack = buildMix rec {
|
||||
name = "quack";
|
||||
version = "0.1.1";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "0hr5ppds4a9vih14hzs3lfj07r5069w8ifr7022fn4j18jkvydnp";
|
||||
};
|
||||
|
||||
beamDeps = [poison tesla];
|
||||
};
|
||||
|
||||
ranch = buildRebar3 rec {
|
||||
name = "ranch";
|
||||
version = "1.8.0";
|
||||
|
@ -1246,6 +1259,19 @@
|
|||
beamDeps = [];
|
||||
};
|
||||
|
||||
remote_ip = buildMix rec {
|
||||
name = "remote_ip";
|
||||
version = "1.1.0";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "0x7d086iik0h5gcwn2bvx6cjlznqxr1bznj6qlpsgmmadbvgsvv1";
|
||||
};
|
||||
|
||||
beamDeps = [combine plug];
|
||||
};
|
||||
|
||||
sleeplocks = buildRebar3 rec {
|
||||
name = "sleeplocks";
|
||||
version = "1.1.2";
|
||||
|
@ -1300,12 +1326,12 @@
|
|||
|
||||
swoosh = buildMix rec {
|
||||
name = "swoosh";
|
||||
version = "1.8.2";
|
||||
version = "1.8.3";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "1nxpcwq7ynvqjp65z544dvdfw7jx9k0m58w4kb0bdbdg1rsvln6h";
|
||||
sha256 = "1isvh6cyiacr4qwy5g883zm204r6sp2h2xas0l2w55m2qyxap6f6";
|
||||
};
|
||||
|
||||
beamDeps = [cowboy ex_aws finch gen_smtp hackney jason mail mime plug_cowboy telemetry];
|
||||
|
@ -1363,6 +1389,45 @@
|
|||
beamDeps = [telemetry];
|
||||
};
|
||||
|
||||
telemetry_metrics_prometheus = buildMix rec {
|
||||
name = "telemetry_metrics_prometheus";
|
||||
version = "1.1.0";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "09jdrv0ik5svi77djycva7a6a8sl05vp2nr7w17s8k94ndckcfyl";
|
||||
};
|
||||
|
||||
beamDeps = [plug_cowboy telemetry_metrics_prometheus_core];
|
||||
};
|
||||
|
||||
telemetry_metrics_prometheus_core = buildMix rec {
|
||||
name = "telemetry_metrics_prometheus_core";
|
||||
version = "1.1.0";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "0sd0j7arhf22ickzdfmq656258dh14kzi61p0vgra007x1zhxl8d";
|
||||
};
|
||||
|
||||
beamDeps = [telemetry telemetry_metrics];
|
||||
};
|
||||
|
||||
telemetry_poller = buildRebar3 rec {
|
||||
name = "telemetry_poller";
|
||||
version = "0.5.1";
|
||||
|
||||
src = fetchHex {
|
||||
pkg = "${name}";
|
||||
version = "${version}";
|
||||
sha256 = "1m1zcq65yz0wp1wx7mcy2iq37cyizbzrmv0c11x6xg0hj8375asc";
|
||||
};
|
||||
|
||||
beamDeps = [telemetry];
|
||||
};
|
||||
|
||||
tesla = buildMix rec {
|
||||
name = "tesla";
|
||||
version = "1.4.4";
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
{
|
||||
"url": "https://akkoma.dev/AkkomaGang/pleroma-fe.git",
|
||||
"rev": "9bf310d5090df86bdb2c4682831ba07d5b95a17c",
|
||||
"date": "2022-12-10T14:51:08+00:00",
|
||||
"path": "/nix/store/k7cjdaf626sll8lb0l98wxym8grr6i4w-pleroma-fe",
|
||||
"sha256": "0dvhgglaxz3z29759f65pvwxl7hbz9gmkffivf3i74rrchdmr0ld",
|
||||
"rev": "b009428814c170dd593ea655df385bb735ce2755",
|
||||
"date": "2022-12-14T12:09:03+00:00",
|
||||
"path": "/nix/store/x3r6mnn7mwb100x63bsmwl9py186bapc-pleroma-fe",
|
||||
"sha256": "02l1nq486x8lfnpr463gz35yl0q18rgjvw3khrchkqn7v2z1jcqw",
|
||||
"fetchLFS": false,
|
||||
"fetchSubmodules": false,
|
||||
"deepClone": false,
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
{
|
||||
"url": "https://akkoma.dev/AkkomaGang/akkoma.git",
|
||||
"rev": "53f21489a2f9737dc2a7f55417f9d9901f750107",
|
||||
"date": "2022-12-14T03:03:08+00:00",
|
||||
"path": "/nix/store/nypfwrvkc1gmk6pbaiypr5684mn5853i-akkoma",
|
||||
"sha256": "0cwr0nhkn3pm77myqkfpdbb186443kz4g8hn9hvflg7bsc6k1ccf",
|
||||
"rev": "4a78c431cfe1373ba09a3c02bc56502063975890",
|
||||
"date": "2022-12-19T20:41:48+00:00",
|
||||
"path": "/nix/store/1iw4ib9cr3gs3a1253ll0bjxzn5hmhas-akkoma",
|
||||
"sha256": "00hihbv0yrpw0bd3vcgb1cvk64h0p36gl66w1jls56wy0fwavwnv",
|
||||
"fetchLFS": false,
|
||||
"fetchSubmodules": false,
|
||||
"deepClone": false,
|
||||
|
|
|
@ -17,11 +17,11 @@
|
|||
},
|
||||
"nixpkgs": {
|
||||
"locked": {
|
||||
"lastModified": 1670992840,
|
||||
"narHash": "sha256-VsTjbxmj338KVfIEL2WLoFrmbhybfxnvRR0GM+TjBhQ=",
|
||||
"lastModified": 1671521405,
|
||||
"narHash": "sha256-pGdaExhAg8ohCLOXJQ06rZqwTmDxsA4iMf+c/J6ozng=",
|
||||
"owner": "NixOS",
|
||||
"repo": "nixpkgs",
|
||||
"rev": "037e57cbafa882034c7bf3a20ac90170339e55f2",
|
||||
"rev": "674ff7aba81b47142a25a7d7883ddf5f1239239a",
|
||||
"type": "github"
|
||||
},
|
||||
"original": {
|
||||
|
|
|
@ -1,9 +1,9 @@
|
|||
{
|
||||
"url": "https://github.com/mautrix/whatsapp",
|
||||
"rev": "a8a98264fb7fb6dc36854add5ae8847fd9ce2503",
|
||||
"date": "2022-12-14T01:04:14+02:00",
|
||||
"path": "/nix/store/ry9cygfkiv68dz9qbmyk4ik84zpf78n8-whatsapp",
|
||||
"sha256": "18v5wjk6zhvhay4nvjbzly69yr6y77ybgnbmp8n15vkhy22zkzji",
|
||||
"rev": "c1538ccfa018354baf4db2ef4352cdb0e33d62a9",
|
||||
"date": "2022-12-16T17:20:51+02:00",
|
||||
"path": "/nix/store/s8bq9cpkl6l1r58c20y3320mmi2chipg-whatsapp",
|
||||
"sha256": "02wbjrrlr6yv75xfgqxsxy6gj6iqw0m3a96ag7ivn0ms6hlqa45j",
|
||||
"fetchLFS": false,
|
||||
"fetchSubmodules": false,
|
||||
"deepClone": false,
|
||||
|
|
|
@ -1 +1 @@
|
|||
sha256-3SBpgN05mQ6t5znKI3E0NIBRjOtL2ITa23SKXdFMDo8=
|
||||
sha256-gxfkPu/ZIv2kKAd1YAue3Vy3+Z7BNG68/Iy0VCW5l4k=
|
||||
|
|
Reference in a new issue