gomod2nix/flake.nix
2022-07-21 09:40:17 +08:00

36 lines
846 B
Nix

{
description = "Convert go.mod/go.sum to Nix packages";
inputs.nixpkgs.url = "github:NixOS/nixpkgs/master";
inputs.utils.url = "github:numtide/flake-utils";
outputs = { self, nixpkgs, utils }:
{
overlays.default = import ./overlay.nix;
templates = {
app = {
path = ./templates/app;
description = "Gomod2nix packaged application";
};
};
defaultTemplate = self.templates.app;
} //
(utils.lib.eachDefaultSystem
(system:
let
pkgs = import nixpkgs {
inherit system;
overlays = [
self.overlays.default
];
};
in
{
packages.default = pkgs.callPackage ./default.nix { };
devShells.default = import ./shell.nix { inherit pkgs; };
})
);
}