47 lines
1.4 KiB
Nix
47 lines
1.4 KiB
Nix
# This file was @generated by cargo2nix 0.10.0.
|
|
# It is not intended to be manually edited.
|
|
|
|
args@{
|
|
release ? true,
|
|
rootFeatures ? [
|
|
"fdidx/default"
|
|
],
|
|
rustPackages,
|
|
buildRustPackages,
|
|
hostPlatform,
|
|
hostPlatformCpu ? null,
|
|
hostPlatformFeatures ? [],
|
|
target ? null,
|
|
codegenOpts ? null,
|
|
profileOpts ? null,
|
|
mkRustCrate,
|
|
rustLib,
|
|
lib,
|
|
workspaceSrc,
|
|
}:
|
|
let
|
|
workspaceSrc = if args.workspaceSrc == null then ./. else args.workspaceSrc;
|
|
in let
|
|
inherit (rustLib) fetchCratesIo fetchCrateLocal fetchCrateGit fetchCrateAlternativeRegistry expandFeatures decideProfile genDrvsByProfile;
|
|
profilesByName = {
|
|
};
|
|
rootFeatures' = expandFeatures rootFeatures;
|
|
overridableMkRustCrate = f:
|
|
let
|
|
drvs = genDrvsByProfile profilesByName ({ profile, profileName }: mkRustCrate ({ inherit release profile hostPlatformCpu hostPlatformFeatures target profileOpts codegenOpts; } // (f profileName)));
|
|
in { compileMode ? null, profileName ? decideProfile compileMode release }:
|
|
let drv = drvs.${profileName}; in if compileMode == null then drv else drv.override { inherit compileMode; };
|
|
in
|
|
{
|
|
cargo2nixVersion = "0.10.0";
|
|
workspace = {
|
|
fdidx = rustPackages.unknown.fdidx."0.1.0";
|
|
};
|
|
"unknown".fdidx."0.1.0" = overridableMkRustCrate (profileName: rec {
|
|
name = "fdidx";
|
|
version = "0.1.0";
|
|
registry = "unknown";
|
|
src = fetchCrateLocal workspaceSrc;
|
|
});
|
|
|
|
}
|